★ TouchArcade needs your help. Click here to support us on Patreon.

Older device whiner thread

12-15-2010, 12:52 PM
#1
Joined: Oct 2009
Location: Greenville, SC
Posts: 8,250
Older device whiner thread

I know this isn't going to get any love for all those people who have newer devices and stick up for developers moving the iOS forward. But nevertheless, I thought we could have a pity party those of us who can't afford to upgrade right now and are sadly missing out on some of the cooler new games of the year.

Tonight, I'll miss Shadow Guardian and Dungeon Defenders. Already cried a river over Infinity Blade.

Don't get me wrong, I strongly agree that developers should push the iOS to its limits with the newer hardware. But that doesn't mean that I have to be happy not being able to play them!

- signed, a sorrow-filled 2nd Gen iPod Touch owner

EDIT: Some have misinterpreted my sarcastic/tongue-in-cheek idea behind this thread. But even though I just wanted to poke a little fun into the subject, I thought it might still be of help others with older devices to keep a list of games unplayable on anything less than a 3GS (This should NOT include games that have a secondary version like Rage that does work on older devices). Please feel free to post about any other games to our growing no-play list and I'll try to keep the OP updated.


Here's what we have so far:

Biofrenzy
Dungeon Defenders
Epic Citadel
Eden World Builder
Infinity Blade
Shadow Guardian
Aralon*

* Some people with 2Gs are playing it, but experiencing crashes so I personally would shy away until it's optimized. The App Store description itself says 3GS and above. Another game I'd love to play!

Last edited by awp69; 12-16-2010 at 06:53 PM.
12-15-2010, 01:11 PM
#2
Joined: Nov 2010
Location: Where you dont live
Posts: 1,662
Epic Citadel
Eden World Builder
Biofrenzy

12-15-2010, 01:14 PM
#3
Joined: Oct 2009
Location: Greenville, SC
Posts: 8,250
Quote:
Originally Posted by Arashi541 View Post
Epic Citadel
Eden World Builder
Biofrenzy
Epic Citadel didn't bother me too much since it was more of a tech demo. But IB certainly hurt.
12-15-2010, 01:28 PM
#4
Joined: Oct 2009
Location: Greenville, SC
Posts: 8,250
I did have a question regarding compatibility. I understand that the Unreal Engine doesn't work on our now "legacy" hardware.

But is there any way that Apple could do an update for older devices to support OpenGL 2.0 (which is the main reason for other non-Unreal Engine games not working)? What do we have, OpenGL 1.1, I think? Or is it just impossible to run 2.0 with our hardware?
12-15-2010, 01:34 PM
#5
Joined: May 2010
Posts: 9,382
What?! Shadow Guardian doesn't run on 2nd gen?!

The end is near!

Currently Enjoying: BUG HEROES 2
Quote:
Originally Posted by JBRUU View Post
Ninny speaks the truth.
12-15-2010, 01:37 PM
#6
Joined: Feb 1983
Location: Barcelona
Posts: 1,268,691
Oprah has a gift for this thread.

12-15-2010, 01:40 PM
#7
I had an iPod touch 1st Gen till up to a few months ago. You guys, with 2nd gens, can definitely live with it. Then I upgraded to an iPhone 4 - and I'm loving every second of it. Spent a year and a bit's savings on it. Hard-earned cash gone into a thing of beauty.

Christmas is coming, you guys should upgrade.
12-15-2010, 01:41 PM
#8
Joined: Mar 2010
Posts: 1,675
I only have an iPod Touch 2nd Gen. Yes, I miss many a good games, but you know what? You cry all day, then your the real loser. I don't care about those games, because I know I'll be playing them on the 25th, when I have more money anyway. And for those who don't have a way of getting a newer device, suck it up and deal with it. Yes, it does suck, but technology has to move on. Time won't stop because you can't afford (Or frankly, don't wanna spend over $200 on) a new device. Learn to deal with it, and you'll be a lot happier with the stuff you have right now.
12-15-2010, 01:49 PM
#9
Joined: Oct 2009
Location: Greenville, SC
Posts: 8,250
Quote:
Originally Posted by bmdino View Post
I only have an iPod Touch 2nd Gen. Yes, I miss many a good games, but you know what? You cry all day, then your the real loser. I don't care about those games, because I know I'll be playing them on the 25th, when I have more money anyway. And for those who don't have a way of getting a newer device, suck it up and deal with it. Yes, it does suck, but technology has to move on. Time won't stop because you can't afford (Or frankly, don't wanna spend over $200 on) a new device. Learn to deal with it, and you'll be a lot happier with the stuff you have right now.
This is what I was trying to avoid. No, I'm not crying all day because of games I can't play. I am happy with what I can play. And I don't have the more like $300 I'd have to spend to upgrade.

I am dealing with it. And, like I said, I don't want devs to stop pushing the limits on the new devices.

Can't we just have a little fun thread for venting what us losers can't play? That's all that was intended (at least on my part).
12-15-2010, 01:51 PM
#10
Joined: Mar 2010
Posts: 145
welcome to the wonderful world of technology, people!

...signature!