★ TouchArcade needs your help. Click here to support us on Patreon.

Angry Birds 1.5 Update question

12-25-2010, 09:26 AM
#1
Joined: Dec 2010
Posts: 20
Angry Birds 1.5 Update question

I have a 1st gen ipod and cant get game center because of that, anyways is the update 1.5 only available if you have game center? i want the new levels. i all ready am missing out on new achievemets for this game and all for the holiday one. which i dont think is fair.

Thanks.
12-25-2010, 09:48 AM
#2
Quote:
Originally Posted by RoylAsult View Post
I have a 1st gen ipod and cant get game center because of that, anyways is the update 1.5 only available if you have game center? i want the new levels. i all ready am missing out on new achievemets for this game and all for the holiday one. which i dont think is fair.

Thanks.
TIme to upgrade to a new device! Go go go!
12-25-2010, 10:06 AM
#3
Joined: Dec 2010
Posts: 20
do you have the money for one?

I might get an iphone for verizon if it ever comes out or an android so i guess then i will finally be able to play it lol
12-25-2010, 11:23 AM
#4
Joined: Oct 2008
Location: In My Head
Posts: 3,358
I don't think it does work on 1st gen devices... My wife is using 1st gen iPhone and she doesn't have the new levels..

Gamecenter:1337brian