★ TouchArcade needs your help. Click here to support us on Patreon.

Question about iPhone 3.0 sdk

04-01-2009, 05:25 PM
#1
Joined: Dec 2008
Posts: 439
Question about iPhone 3.0 sdk

I have a question about this:

"iPhone SDK for iPhone 3.0 can not be used for submitting iPhone OS 2.2.1 applications to the App Store."

So I can't use the 3.0 sdk to submit a 2.2.1 application, even if I select iPhone 2.2.1 when building it?
04-01-2009, 06:12 PM
#2
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
I uploaded iScreamer! 1.1 with the 3.0 SDK, but the project setting was 2.2.1. fyi.

04-01-2009, 06:28 PM
#3
Joined: Dec 2008
Posts: 439
Quote:
Originally Posted by WellSpentYouth View Post
I uploaded iScreamer! 1.1 with the 3.0 SDK, but the project setting was 2.2.1. fyi.
Ah! cool! Thanks!
04-01-2009, 10:03 PM
#4
Joined: Nov 2008
Posts: 61
Quote:
Originally Posted by WellSpentYouth View Post
I uploaded iScreamer! 1.1 with the 3.0 SDK, but the project setting was 2.2.1. fyi.
Isn't this a bit risky? Since the 3.0 SDK is still in beta...
04-01-2009, 10:19 PM
#5
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
Quote:
Originally Posted by Xyzl View Post
Isn't this a bit risky? Since the 3.0 SDK is still in beta...
I guess, but keep in mind that iScreamer! was started on the 2.2.1 SDK, so I don't know what would happen if you started on 3.0...
04-01-2009, 10:44 PM
#6
Joined: Sep 2008
Location: Earth
Posts: 5,252
You just cant submit apps with 3.0 APIS.
If like WellSpentYouth had the settings to 2.2.1 you're fine

I'M ON A MAC MOTHAF*@%!

Cloudcell, Plus+, Baseball Slugger, TTR: dannys95
04-01-2009, 11:34 PM
#7
Joined: Jan 2009
Location: App Tech Studios, USA
Posts: 1,363
Quote:
Originally Posted by dannys95 View Post
You just cant submit apps with 3.0 APIS.
If like WellSpentYouth had the settings to 2.2.1 you're fine
Danny, are you a dev? Or did you get the dev program and then use 3.0 for fun? Just wondering
04-02-2009, 10:49 AM
#8
From my experiences, you need to make sure that your project is set to use the 2.2.1 SDK or older SDKs. Simply not using the 3.0 APIs are not enough since many of the existing ones are either changed, or partically deprecated. The developer site has complete documentation on these changes and additions to make life a whole lot easier!

Founder and Top Exec at TRUESoft Entertainment! Check out our games: Blitz Blok and Blitz Blok Lite!