★ TouchArcade needs your help. Click here to support us on Patreon.

Provisioning Profiles HELP!!!!!

05-07-2011, 06:17 PM
#1
Joined: Aug 2010
Location: NYC
Posts: 42
Provisioning Profiles HELP!!!!!

Hi Guys,

After 5 days of hitting my head against the wall, im starting to get dizzy. I downloaded the latest xcode, updated my phone and itunes. My apple developer membership ended so i renewed it. Then came the dreaded provisioning profiles time. I deleted everything (since i was getting errors) and started from scratch. Created a new license and WWDR certficate from keychain Access, a new App ID (com.companyname.*) and added my iphone 4 to the devices. Created a provisioning profile and i dragged it to organizer, both in library and device. I kept getting errors so then i figured out the bundle identifier was wrong on the .plist file so i changed it to my app ID's name.

Now, the build fails when i want to build on my iphone but it gives me no issues. Before it would tell me what was wrong. The app runs fine on simulator. It is possible that the provisioning profile has an error but i doubt it. I must be overlooking something. Can someone help...I would greatly appreciate it.
05-07-2011, 08:55 PM
#2
Joined: Dec 2009
Location: Berlin, Germany
Posts: 1,674
I have yet to move to xcode4 possibly waiting for another mayor update so they get the kinks ironed out but in xcode3 organizer you could automatically create profiles.. Is this still avaible in x4?

05-07-2011, 10:32 PM
#3
Joined: Mar 2011
Location: Middletown, CT
Posts: 91
If you're working with a project you've previously used you may need to change the code signing value within the project settings. This should point to your new certificate.

To do this, click the top level Project node (the one in blueish gray). Search for "Code Signing". Once found, under "Any iOS SDK" for Debug and Release, change it to point to your new certificate.
05-08-2011, 12:55 PM
#4
Joined: Aug 2010
Location: NYC
Posts: 42
mr. Ugly: yes you can request a provisioning prifile through organizer but that doesnt work for me.

jlakch: I think you are thinking of xcode 3...im usung xcode 4 and i am not using a past program, im starting from scratch.
05-08-2011, 01:31 PM
#5
Joined: Dec 2009
Location: Berlin, Germany
Posts: 1,674
Quote:
Originally Posted by Kriio View Post
mr. Ugly: yes you can request a provisioning prifile through organizer but that doesnt work for me.

jlakch: I think you are thinking of xcode 3...im usung xcode 4 and i am not using a past program, im starting from scratch.


hmm well hard to say then.. i assume you use an xocde4 version that recognizes your iOS devices version..?

maybe someone with xcode4 installed may be able to help out..
05-08-2011, 07:16 PM
#6
Joined: Mar 2011
Location: Middletown, CT
Posts: 91
Quote:
Originally Posted by Kriio View Post
jlakch: I think you are thinking of xcode 3...im usung xcode 4 and i am not using a past program, im starting from scratch.
The same holds true for XCode 4. I'm using XCode 4 and have had to do this when I add new devices to my provision.
05-08-2011, 08:28 PM
#7
Joined: Sep 2010
Location: Atlanta
Posts: 184
I've had provision profile issues before. Make sure the correct one is selected.

In Xcode 4 select the top-level project item for your open project in the file list, select the Target, select the 'Build Settings' tab, search for 'code sign'. Under 'Code Signing Identity'>Debug>Any iOS SDK, make sure the correct provisioning profile is selected (usually they have dates listed next to them so select the latest one).

Hope this helps
05-09-2011, 08:46 AM
#8
Joined: Aug 2010
Location: NYC
Posts: 42
I was certain this would fix it, but sadly it did not. Instead of Any iOS SDK i put my iphone 4 and added the correct provisioning profile (since i deleted all the rest, i only have one). Still, once i hit build, the building bar only goes to 10%-ish and the build fails...with no issues. I just think xcode is picking up the old provisioning profiles from somewhere.

Last edited by Kriio; 05-10-2011 at 03:21 PM. Reason: thread bumping
05-14-2011, 11:09 AM
#9
Joined: Aug 2010
Location: NYC
Posts: 42
any more ideas?
05-15-2011, 02:07 AM
#10
Joined: Sep 2010
Location: Morestel, France
Posts: 572
- delete all the profiles from organizer and iphone 4.
- redownload your profile and drop them on xcode.
- make sure you have 3 entries in code signing identity:
Code signing identity
Any SDK
Any IOS

Code Signing Entitlements: empty for everything but only include your Entitlements.plist only for the ADHOC build.

Delete your build folder and recompile (don't forget to cross your finger).

JC